Windows no longer shows CD/DVD devices - Advanced fix

Knowledgebase Article : EE6000150   |    Print this Article


Issue

After installing or uninstalling Roxio software, Windows no longer shows CD / DVD
devices in My Computer.


Cause

CD Burning software must utilize specific windows registry entries in order to access
optical devices attached to your computer. At times these entries may become
corrupt during the install/uninstall process, or if there are/were multiple CD recording
application installed on your computer


Resolution

This resolution is intended to be used only if Knowledgebase article CD/DVD drives missing after installation (EEZ000005) did not resolve the issue. Roxio recommends that the procedure described in the said article be carried out prior to proceeding.

Warning: Please keep in mind that the steps included in this article will require manual editing of your system registry. Editing your registry incorrectly could cause serious problems that may require you to reinstall your operating system. Please proceed at your own risk.

To recover lost drive by manually removing Upper and Lower filter values within Windows system registry

  1. Uninstall Easy CD Creator or Easy CD and DVD Creator through Add/Remove Programs
  2. Open the registry editor (Start --> Run --> type "regedit")
  3. Remove the Upper and Lower values from the following registry path

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}

    • Expand the HKEY_LOCAL_MACHINE key by double clicking it.
    • Expand the SYSTEM Key
    • Expand the CurrentControlSet Key
    • Expand the Control Key
    • Expand the Class Key
    • Highlight the {4D36E965-E325-11CE-BFC1-08002BE10318} key
    • Locate the Upperfilters and Lowerfilters values in the right pane
    • Collapse all open registry keys and close the registry editor


  4. Restart your computer
  5. Open My Computer
  6. Windows should now see your CD/DVD drives
At this point Roxio software may be reinstall if desired. Updates can be found here.


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Article Details

Last Update : 6/4/2009

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Knowledgebase Article : EE6000150   |    Print this Article