CD/DVD drives missing after installation

Knowledgebase Article : EEZ000005   |    Print this Article


Issue

After installing or uninstalling Roxio software, Windows no longer shows CD / DVD devices in My Computer


Cause

CD Burning software must utilize specific windows registry entries in order to access optical devices attached to your computer. At times these entries may become corrupt during the install/uninstall process, or if there are/were multiple CD recording application installed on your computer


Resolution

Note: This issue was resolved in Creator 8 and higher. Visit the Roxio Upgrade Center for the latest version of Creator or call our Inside Sales Team at 1-877-697-6946 (Monday - Friday, 9:00 A.M. to 6:00 P.M., EST - excluding Roxio holidays).

We currently have a resolution for 2 separate scenarios

Scenario 1:

Applies a fix for devices missing when Roxio Easy CD Creator 4, 5 or Easy CD & DVD Creator 6 are installed on your computer

Scenario 2:

Applies a fix for drives missing after any version of Easy CD Creator or Easy CD & DVD Creator have been completely uninstalled.

Note: If the following solutions do not address your issue, please see our general Knowledgebase article Drives are missing after install for further steps

Scenario 1: (Roxio software is installed on your computer)

  1. Download DriveFix_Installed.exe.
  2. Double click the file and follow the instruction
  3. Click “Yes” to restart your computers
  4. Open “My Computer”
  5. Windows should now see your devices


Scenario 2: (Roxio software was uninstalled from your computer)

  1. Download DriveFix_Uninstalled.exe.
  2. Double click the file and follow the instructions

If the above steps do not resolve the issue, you may need to apply the fix manually with the article Windows no longer shows CD/DVD devices - Advanced fix.

If the solution does not resolve your issue, you can call the Premium Tech Support line at 1-866-434-9871 (Monday - Friday, 11:00 A.M. to 6:00 P.M., EST - excluding Roxio holidays) for $1.89 a minute (complete details).


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Article Details

Last Update : 6/24/2008

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Knowledgebase Article : EEZ000005   |    Print this Article